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Administrative Training
We’ll Start at 0900

Michael Maskalans
Trainer
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Training Objectives

• Introduce Pictometry
– Electronic Field Study 
– Image Library

• Understand the Image Library file structure
• Understand Subwarehousing for distribution
• Address search setup and limitations
• Configuration Editor use and capabilities
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Pictometry International

• Based in Rochester, New York
– “Imaging Capital of the World”

• Provides two main products:
– Electronic Field Study
– A Library of Geo-Referenced Aerial Imagery

“See Everywhere, Measure Anything, Plan Everything!”
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Electronic Field Study (EFS)

EFS is the application that Pictometry has 
provided which allows you to utilize the 
imagery we are delivering. In this program 
you will be able to locate, analyze and 
annotate our images.
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• EFS must be installed to every workstation 
that will be analyzing imagery from the 
delivered Image Warehouse
– Hardware Specifications for EFS
– Setup of the EFS Application
– Documentation 

Electronic Field Study (EFS)
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EFS Application

• Minimum Hardware Specifications:
– Windows NT/ 2000/ XP
– Pentium III 600MHz
– 128MB of RAM (256MB+ recommended)
– Display Resolution 1024x768
– Hard Drive Space

• EFS Application – 50MB of available space
• Image Warehouse – depends upon coverage; usually via network

– Pointing Device (mouse, touchscreen)
– Network Interface Card if the warehouse is stored on the network

• Wired or wireless, 100 Mbit recommended
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EFS Application

• Setup 
– Install EFS Application
– Available Documentation
– Connect EFS to an Image Warehouse



EFS 2.6r3 8

• Setup.exe
– On the CD that shipped

• Location of setup.exe
– On the Hard Drive Media that shipped

• Location of setup.exe
– From a folder that has been created on your network

• Silent install document available

• Registry Keys:
• HKEY_CURRENT_USER
• HKEY_LOCAL_MACHINE

EFS Application Setup
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Documentation

• EFS 2.6 Quick Start Guide
• EFS 2.6r2 Release Notes (describes changes 

from r1)
• EFS 2.6 User Guide Supplement
• Pictometry Quick Reference

Make this available to whomever needs it.  You 
can print as many as needed.
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The Image Library
• The directory structure that contains all Pictometry 

data. Contains:
– EFS Application Data
– Arial images

• Need to understand:
– What our images are
– How we store them (what the directory structure looks like)
– Image Library Storage Space Requirements
– Network Traffic Pattern and Workstation Memory 
– How to Connect
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Image Basics

• Two image types
– Orthogonal
– Oblique

• Two image levels (altitudes)
– Community
– Neighborhood
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Pictometry Image Types 

• Orthogonal
– Shot from straight above
– Oriented “North-up”
– We refer to them as “Orthos”

• Oblique
– Shot at a 40-45 degree angle
– Shot looking to the North, South, East or West
– Give perspective
– Make us unique in geospatial imaging
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Pictometry Image Levels

• Community
– Shot from ~5-6,000 ft.
– Average resolution (GSD): 2 feet per pixel
– Comparable to the best civilian/commercial 
satellite imagery

• Neighborhood
– Shot from ~2-2,500 ft. 
– Average resolution (GSD): 6 inches per pixel
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What it looks like
in Windows Explorer
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Library Storage Space Requirements

• The requirements depend on the physical size of 
your Pictometry Library

• Library contains a Warehouse of Imagery
– Each Image is 6-10MB in size
– Your entire Library is about 40 GB in size

• Network Storage or Local Storage
• Need enough space to store the data users need

– Delivered Warehouse can be ‘Sub-Warehoused’



EFS 2.6r3 16

Network Considerations
Network Traffic and Workstation Memory

• Image transfers to workstation when an 
image is selected from ‘Thumbnail Window’
and into the ‘Image Window’

• Traffic on the network occurs at this point
• Each Image opened in the ‘Image Window’

consumes about 18MB of RAM
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Connecting EFS to a Warehouse
• This needs to be done at every workstation

– Part of the installation process of EFS
• UNC Naming (\\server\share) vs. Drive 

Mapping (G:\)
• Here’s how:

– Click on Image Tool Properties in the tool bar 
or go to “Navigate” > “Image Tool Properties”
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File has a .PIW Extension
• To see file extensions, you 

need to have Windows 
configured to display them
– “Tools” > “Folder Options” > 

“View” Tab
– Deselect “Hide file extensions for 

known file types”

• Or look for the icon:
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The EFS File Structure

• EFS file types & associated icons
• Library structure details
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File Extensions and Icons
.PMI

– Pictometry Map Image
– Ortho Images and Maps

.PSI
– Pictometry Shot Image
– Oblique Images

.PLF
• Pictometry License File
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File Extensions and Icons
.PWF

– Pictometry Workspace File

.PEF
– Pictometry Elevation File

.PIW
– Pictometry Image Warehouse

.PAX
– Pictometry Address Setup
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Library

DEMs

Maps and GIS

Workspace Files

Warehouse

Clusters

Sectors

Image Library File Structure

All Images stored
at this level
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Library Directory
• Starting point of the Pictometry directory structure
• Example: NYMONR03-93-LIB

– [State][County][Year]-[Quality]-LIB (more later)
• Contains the following directories

– DEMs
– Maps and GIS
– *-WHS (Warehouse)
– Starting Workspace Files (*.pwf)
– Optional Folders 

• Users only need read access at this directory
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Library Directory
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Pictometry Workspace File
• Workspace file is savable

– Allows EFS users to access previous work 
at a later time
–Can start EFS by accessing a saved 
Workspace File (.pwf)
– Can be shared between users

• Can be saved locally or on a network drive.
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Pictometry Workspace File

• Files have a .PWF extension
• Can reside anywhere on a local PC or network 

drive
– Workspace files are local.  Links to local files will only 

work on the original workstation; drive map dependant
• Should be named and stored in a logical manner 

for later retrieval, but no particular order is 
enforced by EFS

• Will be discussed in the User Training 
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• To make EFS access easy for Users
– Create a default “Starter Workspace” for 

everyone’s use
– Save the workspace to a protected network 

location
– Create a shortcut on users’ Desktops to this 

default workspace 

Pictometry Workspace File
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Library 

DEMs

Maps and GIS

Workspace Files

Warehouse

Clusters

Sectors

Image Library File Structure

All Images stored
at this level
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DEMs Directory
This directory contains proprietary elevation files 
that represents elevation of a geographic area. These 
files are either derived from a USGS DEM (Digital 
Elevation Model) or from customer-supplied data.  
We refer to them as Pictometry Elevation Files

•These files have a .PEF extension

•These files only need read access by end users
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DEMs Directory
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Library 

DEMs

Maps and GIS

Workspace Files

Warehouse

Clusters

Sectors

Image Library File Structure

All Images stored
at this level
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Maps and GIS Directory
This directory contains Base Starter Maps,  shape files and 
Address Search Index files.  Base Starter Maps are used when 
EFS is launched without using a workspace file on a 
workstation. 

•There are a variety of file extensions in this directory

•These files only need read access by end users

•GIS Personnel need write access 
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Maps, Ortho Images and Scripts
.PMI 
.PGS

Shape Files
.SHX    .PDX
.SHP     .PAX
.DBF

Images with World Files
.JPG
.JGW
.AUX

Data Files
.MD1, .LD1, etc.

Maps and GIS Directory
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Maps and GIS Directory
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Library 

DEMs

Maps and GIS

Workspace Files

Warehouse

Clusters

Sectors

Image Library File Structure

All Images stored
at this level
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Image Warehouse Directory
This is the directory structure Pictometry uses as a 
geographic database. EFS uses index files to find photos 
when users click on PSI or PMI Maps and other GIS 
images. Indexing these files within the Warehouse allows 
EFS to easilly reference them to their geographic location.

•Files have a .PIW extension

•They reside in the WHS, Cluster and Sector directories (folders)

•Users only need read access to these files
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Image Warehouse Directory
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Naming Convention Overview

Cluster Folder

Sector Folder

NYMONR03-093-LIB

State County Year of image capture

NYMONR021021 cluster

State County Cluster Number

NYMONR024021

State County Sector Number

Library Folder

Warehouse Folder NYMONR03-093-WHS
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Naming Conventions 
Ortho  Files

NYMonr025021CommOrtho25_030415.PMI

State County Sector

Community Orthogonal = CommOrtho

Neighborhood Orthogonal = NeighOrtho

Type of Image Date Shot File Extension

.PMI = OrthoYYMMDD
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Naming Conventions 
Oblique Files

NYMonr025021NeighObliq34E_030610.PSI

State County Sector

Community Oblique = CommObliq

Neighborhood Oblique = NeighObliq

Type of Image Shot Date File Extension

.PSI = Oblique

Shot Direction

YYMMDD
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Sub Warehousing

• Reasons for creating a Sub Warehouse
• Warehouse Structure Review
• Understanding the Sector Map
• Sector Identification
• Parceling the Data
• Building the New Warehouse
• Connecting to the New Warehouse
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Reasons to Sub Warehouse

• You may not want or need to distribute the 
entire warehouse of images
– Limited storage space on users’ machines
– Want to selectively parcel out the images
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Warehouse Structure Review

• Region of coverage divided into 1x1 mile 
Sectors
– Start in NW corner with 001001

• Sectors grouped into 5x5 mile Clusters
– Clusters named by NW sector

• Stored in the WHS as such:
– Cluster

• Sector
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About the Sector Map

• The Sector Map is always rectangular
• Numbering starts in the northwesternmost

corner with 001001
• Sectors with no images will not have Sector 

Folders
• Clusters with no images in any Sector will not 

have Cluster Folders



EFS 2.6r3 47

Sector Map Workspace
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Map Key

• Purple Sectors
– Only Community-level coverage

• Green Sectors
– Both Community and Neighborhood-level 

coverage
• Red Outline

– Sector Map Bounding Line
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• Sectors reside in Clusters

Sector
1 sq.mile

Cluster
25 sq.miles
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Zoomed in Sector Map
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Sector Information
Sector Number 015012
Contains:
Community Orthos (COR’s)
Community Obliques (COB’s)
Neighborhood Orthos (NOR’s)
Neighborhood Obliques (NOB’s)
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Sector Identification

• Need to identify which sectors you want to 
subwarehouse

• Two effective methods:
– The image name
– The sector map
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NYMonr025021NeighObliq34E_030610.PSI

State County Sector

Community Oblique = CommObliq

Neighborhood Oblique = NeighObliq

Type of Image Shot Date File Extension

.PSI = Oblique

Shot Direction

YYMMDD

Sector Identification

• Using the image name:
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• Using the Sector Map:
• Open “Sector Map Workspace.PWF”

– Typically found in the ‘–LIB’ Directory
• Look at the map to find the sectors 

containing your region of interest
– Can zoom in
– Can use the Query Tool
– Note: we drop leading zeros on the sector map

Sector Identification
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Parceling the Data

• In order to get the desire sectors’ pictures, you 
need to know what cluster the sectors are in

• We count by (row, column), and name as “rrrccc”
– Your cluster-level options are 001, 006, 011, 016…
– Always round down to the nearest 5n + 1 for both row 

and column
– Will always be the next lowest number ending in 1 or 6
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Sector 024032

Row 024
Rounds down to 021

Column 032
Rounds down to 031

Results in desired Cluster
Cluster 021031

Row 024

Column 032

Translate to directory name
NYMonr021031 cluster
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Cluster Quiz! 
• Sector 014026 • Cluster 011026

• Sector 021032

• Sector 033044

• Cluster 021031

• Cluster 031041
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Subwarehouse Preparation Overview

• Reference the Sector Map for the desired 
geographic area

• Record the Sector numbers desired
• Determine the Clusters that the Sectors reside in 

(so you can find the desired Sector folder)
• Create a blank directory structure that matches the 

original Warehouse for the desired Clusters
• Copy desired Sectors to the corresponding newly 

created Cluster folders
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Subwarehouse Building

• Open any warehouse (.piw) file
– The simplest way to do this is to create a new warehouse
– File > New… > Warehouse > [OK]

• If this option is not available, check “Advanced User Mode” under 
File > System Setup

• Select Edit > Auto Build Warehouse
• Navigate to the Parent Folder of your new Sub 

Warehouse structure and click Save
– Note: This step may take time.  .PIW files are rebuilt 
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Distribute Subwarehouse

• Copy the resulting Subwarehouse to 
wherever it needs to reside 

• Connect EFS to this Sub Warehouse for the 
users who will use it
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Connecting to a Subwarehouse
Select it like any other warehouse:
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Address Searching

• EFS has the ability to perform a basic 
address search on a shape file or SDE 
database.

• Addresses must be properly formatted in the 
database: all fields must be separated for an 
effective search

• We only actually search the address number 
and street name fields.
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Address Search Setup Overview

• Select the file
• Map its fields to ours
• EFS will automatically create a PDX index 

of the street number and name fields.  
• Can save the search setup so other users can 

import it (PAX file)
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Address Search

• Selecting the Shape file to search:
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Address Search

• Mapping Fields
– Need to select the proper 

database field to map to 
each of our search fields.

• Then name the set, save it, 
and save a PAX to share 
the search setup (shape 
file location, field setup, 
set name)
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Address Search Limitations

• We only search based on number and name, other 
fields are for display purposes only and will not
filter results

• If a street name search is fully satisfied by a result, 
partial matches will not be returned
– A search for “willow” will find Willow St, Willow Ave 

but NOT Willow Creek Blvd.  “willo” or “willow*”
will find all of the above.

– Address searches do not stop when fully satisfied.  “2 
South Ave” will return 2 South St, 20 South Ave, 27 
South Ave and 2157 South Ave (but not 2 Southern Tr)
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Address Search Results

• By default, a parcel search result is returned as a 
1px black solid outline

• To change this, the shape file being searched must 
be added to the workspace.
– Right click and go to Search [layerName] and then the 

properties tab.

• The layer need not be present in the workspace to 
be searchable by the Address Search function, but 
must be added to change this preference.
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EFS Configurations

• Tools > Customize > Configs tab
– Single-user
– Allows sharing of toolbar customizations

• EFS Configuration Editor.exe
– Multi-user: single PCF stored in network location.
– Allows configuration updates of settings stored in the 

registry: toolbar configs, image warehouses, tool 
settings, etc

– Can force updates/changes/etc.
– Can force config to load on application startup.



EFS 2.6r3 69

Training Summary

• Introduce Pictometry
– Electronic Field Study 
– Image Library

• Understand the Image Library file structure
• Understand Subwarehousing for distribution 
• Address search setup and limitations
• Configuration Editor use and capabilities
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